Overview

Help > Overview
Overview

This chapter presents the information how to use this manual and quick start if you are already familiar with Microsoft Visual Studio and C# programming language.

© 2021 JYTEK company. All rights reserved.


Introduction

Help > Overview > Introduction
Introduction

PCIe/PXIe-5310 Series Simultaneous DAQ provide 16-channel, 16 bits resolution, up to 5M samples per second per channel. It also has 16 digital IO lines. PCIe/PXIe-5310 can be run on PCIe, PXIe, TXI(Thunderbolt) and USB bus (coming soon) platforms. Depending on the model number, a 5310 series provide different sampling rate as shown in Table 1 .

Table 1 5310 Family and Main Features

Table 2 5310 on Different Bus


Main Features

Help > Overview > Main Features
Main Features

l 16 differential analog input channels

l 16 bits ADC

l 4 voltage ranges: ±10 V / ±5 V / ±2 V / ±1 V

l 256M samples of FIFO buffer

l 8 ports digital IO, 2 channels per port

l Analog/Digital/Software Trigger


Abbreviations

Help > Overview > Abbreviations
Abbreviations

AI: Analog Input

DI: Digital Input

DO: Digital Output

DAQ: Data AcQuisition

ADC: Analog-to-Digital Conversion

PFI: Programmable Function Interface

DIFF: Differential


Learn by example

Help > Overview > Learn by example
Learn by example

JYTEK has added Learn by Example in this manual. We provide many sample programs for this device. Please download and install the sample programs for this device. You can visit our web www.jytek.com to search for the example file or you can download a JYPEDIA excel file from our web. Open JYPEDIA and search for JY5310 in the driver sheet, select the latest JY5310 Examples.zip. This will lead you to download the sample program for this device. In addition to the download information, JYPEDIA also has a lot of other valuable information, JYTEK highly recommend you use this file to obtain information from JYTEK.

Figure 1 JYPEDIA Information

In a Learn by Example section, the sample program is in bold style such as Analog Input-->Winform AI Continuous MultiChannel Soft Trigger; the property name in the sample program is also in bold style such as SamplesToAcquire; the technical names used in the manual is in italic style such as SampleRate. You can easily relate the property names in the example program with the manual documentation.

In an Learn by Example 5.2~5.5 section, the experiment is set up as follow. The PCIe/PXIe-5310 is connected to a TB-68 terminal block. A signal source is also connected to the same terminal block as shown Figure 2 .

Figure 2 Experiment Setup

The TB-68 is shown below as Table 3 . In the rest of this manual, the wire connection in each Learn by Example section will be given by the pin numbers only.

Table 3 TB-68 Front Panel for 5310 Series


Analog Input Specifications

Help > Hardware Specifications > Analog Input Specifications
Analog Input Specifications

Table 4 Analog Input Specifications


AI Accuracy

Help > Hardware Specifications > AI Accuracy
AI Accuracy

Your measurement accuracy is calculated by following fomular:

For example at 5V range and 24 Hours column, if your measurement is 2V, the accuracy of this measurement is:

You can also get a good estimate by looking up the full scale accuracy for each range.

Table 5 AI Accuracy


Temperature Coefficients

Help > Hardware Specifications > Temperature Coefficients
Temperature Coefficients

When the operating temperature is outside the last calibration temperature, the accuracies in the table need to be adjusted. For example, In Table 4, if the operating temperature is 3°C outside the last calibration temperature range, the temperature adjustment at 5V range will be 3*(0.0023% of reading + 0.0153% of range) = (0.0069% of reading + 0.0459% of range). This adjustment needs to be added to 24 Hour or 90 Days accuracy entries. In the case of the 24 Hour column, the accuracy entry becomes (0.0092% of reading + 0.0612% of range). The same 2V measurement now has the accuracy:


AI Bandwidth

Help > Hardware Specifications > AI Bandwidth
AI Bandwidth

Table 6 AI Bandwidth

图表, 折线图 描述已自动生成

Figure 3 -3dB Bandwidth


CMRR

Help > Hardware Specifications > CMRR
CMRR

Table 7 CMRR

Figure 4 CMRR


Adjacent channel

Help > Hardware Specifications > Crosstalk > Adjacent channel
Adjacent channel

Table 8 Crosstalk (Adjacent channel)


Non-adjacent channel

Help > Hardware Specifications > Crosstalk > Non-adjacent channel
Non-adjacent channel

Table 9 Crosstalk (Non-adjacent channel)


Digital IO Specifications

Help > Hardware Specifications > Digital IO Specifications
Digital IO Specifications

Table 10 Digital IO Specifications


PFI Specifications

Help > Hardware Specifications > PFI Specifications
PFI Specifications

Table 11 PFI Specifications


Power Specification

Help > Hardware Specifications > Power Specification
Power Specification

Table 12 Power Specification


Physical and Environment

Help > Hardware Specifications > Physical and Environment
Physical and Environment

Table 13 Physical and Environment


Front Panel and Pin Definition

Help > Hardware Specifications > Front Panel and Pin Definition
Front Panel and Pin Definition

Figure 5 PCIe/PXIe-5310 Front Panel

PCIe/PXIe-5310 series are connected to incoming signals by one 68-pin cable for 16 analog input channels and 16 DIO. Table 14 and Table 15 show the pin definition for PCIe/PXIe-5310 series respectively.

Table 14 5310 Pin Define

Table 15 Notes to Legend


System Requirements

Help > Software > System Requirements
System Requirements

PCIe/PXIe-5310 Modules can be used in a Windows or a Linux operating system.

Microsoft Windows: Windows 7 32/64 bit, Windows 10 32/64 bit.

Linux Kernel Versions: There are many Linux versions. It is not possible JYTEK can support and test our devices under all different Linux versions. JYTEK will at the best support the following Linux versions.

Table 16 Supported Linux Versions


System Software

Help > Software > System Software
System Software

When using PCIe/PXIe-5310 in the Window environment, you need to install the following software from Microsoft website:

n Microsoft Visual Studio Version 2015 or above.

n .NET Framework version is 4.0 or above.

.NET Framework is coming with Windows 10. For Windows 7, please check .NET Framework version and upgrade to 4.0 or later version.

Given the resources limitation, JYTEK only tested PCIe/PXIe-5310 with .NET Framework 4.0 with Microsoft Visual Studio 2015. JYTEK relies on Microsoft to maintain the compatibility for the newer versions.


C# Programming Language

Help > Software > C# Programming Language
C# Programming Language

All JYTEK default programming language is Microsoft C#. This is Microsoft recommended programming language in Microsoft Visual Studio and is particularly suitable for the test and measurement applications. C# is also a cross platform programming language.


PCIe/PXIe-5310 Hardware Driver

Help > Software > PCIe/PXIe-5310 Hardware Driver
PCIe/PXIe-5310 Hardware Driver

After installing the required application development environment as described above, you need to install the PCIe/PXIe-5310 hardware driver.

JYTEK hardware driver has two parts:

n the shared common driver kernel software (FirmDrive)

n the specific hardware driver.

Common Driver Kernel Software (FirmDrive): FirmDrive is the JYTEK’s kernel software for all hardware products of JYTEK instruments. You need to install the FirmDrive software before using any other JYTEK hardware products. FirmDrive only needs to be installed once. After that, you can install the specific hardware driver.

Specific Hardware Driver: Each JYTEK hardware has a C# specific hardware driver. This driver provides rich and easy-to-use C# interfaces for users to operate various PCIe/PXIe-5310 function. JYTEK has standardized the ways which JYTEK and other vendor’s hardware are used by providing a consistent user interface, using the methods, properties and enumerations in the object-oriented programming environment. Once you get yourself familiar with how one JYTEK DAQ card works, you should be able to know how to use all other DAQ hardware by using the same methods.

Note that this driver does not support cross-process, and if you are using more than one function, it is best to operate in one process.


Install the SeeSharpTools from JYTEK

Help > Software > Install the SeeSharpTools from JYTEK
Install the SeeSharpTools from JYTEK

To efficiently and effectively use PCIe/PXIe-5310, you need to install a set of free C# utilities, SeeSharpTools, from JYTEK. The SeeSharpTools offers rich user interface functions you will find convenient in developing your applications. They are also needed to run the examples come with PCIe/PXIe-5310 hardware. Please register and down load the latest SeeSharpTools from our website, www.jytek.com .


Running C# Programs in Linux

Help > Software > Running C# Programs in Linux
Running C# Programs in Linux

Most C# written programs in Windows can be run by MonoDevelop development system in a Linux environment. You would develop your C# applications in Windows using Microsoft Visual Studio. Once it is done, run this application in the MonoDevelop environment. This is JYTEK recommended way to run your C# programs in a Linux environment.

If you want to use your own Linux development system other than MonoDevelop, you can do it by using our Linux driver. However, JYTEK does not have the capability to support the Linux applications. JYTEK completely relies upon Microsoft to maintain the cross-platform compatibility between Windows and Linux using MonoDevelop.


Operating PCIe/PXIe-5310

Help > Operating PCIe/PXIe-5310
Operating PCIe/PXIe-5310

This chapter provides the operation guides for PCIe/PXIe-5310, including AI and programmable I/O interface, etc.

JYTEK provides extensive examples, on-line help and documentation to assist you to operate the PCIe/PXIe-5310 board. JYTEK strongly recommends you go through these examples before writing his own application. In many cases, an example can also be a good starting point for a user application.


Quick Start

Help > Operating PCIe/PXIe-5310 > Quick Start
Quick Start

After you have installed the driver software and the SeeSharpTools, you are ready to use Microsoft Visual Studio C# to operate PCIe/PXIe-5310.

If you are already familiar with Microsoft Visual Studio C#, the quickest way to use PCIe/PXIe-5310 is to go through our extensive examples. We provide source code of our examples. In many cases, you can modify the source code and start to write your applications.

We also provide Learn by Example in the following sections. These examples will help you navigate and learn how to use this PCIe/PXIe-5310.


Data Acquisition Methods

Help > Operating PCIe/PXIe-5310 > Data Acquisition Methods
Data Acquisition Methods

PCIe/PXIe-5310 uses a simultaneous method to acquire analog data, meaning there is sixteen ADC chip on the device and each input channel uses individual ADC to capture data. In the simultaneous acquisition mode, you need to configure AI channels and set up some parameters through PCIe/PXIe-5310 driver software. The most important parameters are Data Acquisition mode, Sample Rate, SamplesToAcquire, Channel, and Analog Input Terminal Type.

AI Acquisition mode (AIMode): PCIe/PXIe-5310 provides 4 acquisition modes, Continuous, Finite, Single Point, Record described in details in Section 4.2.1 to 4.2.4 .

SampleRate: How fast multi-channel data are collected per second per channel. Example, if your sample rate is 1000Hz, you acquire two channels of data, you will have 2000 points/second.

SamplesToAcquire: This parameter behaves differently in the different AI acquisition modes. In the continuous acquisition mode, SamplesToAcquire is the buffer size used in the AI acquisition task; in the finite acquisition mode, it is to specify the number of samples to capture.

Channels: how many channels do you want to collect data. You can set up the channels in different orders, for instance 2,3,1,0. The acquired data will be arranged in the way you specified. In this particular case, Channel_Count is 4.

Once the Sample Rate is set, the actual hardware sampling rate is achieved by internal clock or external clock source. The sample clock source is also configured by software. Data acquisition sequence is shown in Figure 6 .

Figure 6 AI Simultaneous Mode Acquisition


Continuous Acquisition

Help > Operating PCIe/PXIe-5310 > Data Acquisition Methods > Continuous Acquisition
Continuous Acquisition

An AI acquisition task will acquire the data continuously until the task is stopped when you start the task in the Continuous acquisition mode. You will need to configure the appropriate buffer size by the parameter, SamplesToAcquire, to achieve the best performance of capture and display.

You use the sample program Analog Input --> Winform AI Continuous to learn more about Continuous Acquisition


Finite Acquisition

Help > Operating PCIe/PXIe-5310 > Data Acquisition Methods > Finite Acquisition
Finite Acquisition

In the Finite Acquisition mode, an AI acquisition task will capture specific number of samples by the parameter, SamplesToAcquire.

You use the sample program Analog Input --> Winform AI Finite to learn more about Finite Acquisition.


Single Acquisition

Help > Operating PCIe/PXIe-5310 > Data Acquisition Methods > Single Acquisition
Single Acquisition

In the Single Acquisition mode, it is to capture a single sample for each acquisition.


Record Acquisition

Help > Operating PCIe/PXIe-5310 > Data Acquisition Methods > Record Acquisition
Record Acquisition

AI Task will continuously capture the data and then save them to a storage disk. During the capturing process, user can preview the captured data randomly when the capturing process is available. The mode is particularly useful for high-speed acquisition and recording applications.

You can use sample program: Record -->Winform AI Finite Streaming to learn more about the single point Acquisition.


Learn by Example 4.2

Help > Operating PCIe/PXIe-5310 > Data Acquisition Methods > Learn by Example 4.2
Learn by Example 4.2

n Connect the two signal source’s positive outputs Ch1, Ch2 to PCIe/PXIe-5310 AI Ch0 positive (AI0+, Pin#66) and AI Ch1 positive (AI1+, Pin#63), two negative terminals to AI Ch0 negative (AI0-, Pin#32) and AI Ch0 negative (AI1-, Pin#29) as shown in Figure 2 and Table 3 . (AI0+, AI0-) and (AI1+, AI1-) consist of two channels of DIFF inputs.

n Set the signal source Ch1’s output to sinewave (f=1k, Vpp=5v), Ch2’s output to squarewave (f=1k, Vpp=3v).

n Open Analog Input-->Winform AI Continuous MultiChannel, set the following numbers as shown. This sample program will continuously acquire data from multiple channels.

Figure 7 MultiChannel Continuous Parament

Ø SampleRate is set by Sample Rate

Ø Samples to Acquire is the samples to be acquired for each channel in one block. The continuous mode will acquire blocks after blocks until Stop button is pressed.

n When Start is clicked, the acquisition starts. The result is shown below.

Figure 8 Multichannel Continuous Acquisition


Analog Input Terminal Type

Help > Operating PCIe/PXIe-5310 > Analog Input Terminal Type
Analog Input Terminal Type

The PCIe/PXIe-5310 only provides one analog input terminal type: Differential (DIFF). In the differential mode you can connect ground-referenced signal to the PCIe/PXIe-5310. Connect positive side of signal to AI+ terminal, negative side of signal to AI- terminal as shown in Figure 9 . Please see the provided software examples for more information.

Figure 9 Differential Mode for Grounding Signal

If the measured signal is floating, it is quite often that the common mode voltage will appear. To reduce this effect on the measurement accuracy, a resister can be added as shown in Figure 10 . The value of this resister depends on the impedance of the signal source. As a rule of thumb, R should be 1000 times of the signal source output impedance, roughly 10 KΩ to 100 KΩ. At this level, R has very little impact on the measurement.

Figure 10 Differential Mode for Floating Signal


Trigger Source

Help > Operating PCIe/PXIe-5310 > Trigger Source
Trigger Source

There are 4 trigger types:

n Immediate trigger

n Software trigger

n analog trigger

n digital trigger

The trigger type is a property and set by driver software. Please find the provided software examples for more information.


Immediate trigger

Help > Operating PCIe/PXIe-5310 > Trigger Source > Immediate trigger
Immediate trigger

The module will acquire the signal immediately after executing the AI Task without any trigger condition setting by default.


Learn by Example 4.4.1

Help > Operating PCIe/PXIe-5310 > Trigger Source > Immediate trigger > Learn by Example 4.4.1
Learn by Example 4.4.1

n Use the same sample program and connection as in Learn by Example 4.2 .

Figure 11 Immediate Trigger Paraments

Ø With Immediate trigger you can click Start to begin the task instead of sending a trigger signal.


Software Trigger

Help > Operating PCIe/PXIe-5310 > Trigger Source > Software Trigger
Software Trigger

The analog acquisition task will wait on the software trigger signal in the software trigger mode until receiving a software trigger signal from driver, then AI task will start to acquire the data


Learn by Example 4.4.2

Help > Operating PCIe/PXIe-5310 > Trigger Source > Software Trigger > Learn by Example 4.4.2
Learn by Example 4.4.2

n Connect the signal source’s positive terminal Ch1 to PCIe/PXIe-5310 AI Ch0 positive (AI0+, Pin#66), the negative terminal to AI Ch0 negative (AI0-, Pin#32) as shown in Figure 2 and Table 3 . (AI0+, AI0-) consists of a DIFF input.

n Set the signal source Ch1’s output to sinewave signal (f=5Hz, Vpp=5v).

n Open Analog Input-->Winform AI Continuous Soft Trigger, set the following numbers as shown.

Figure 12 SoftwareTrigger Paraments

Ø Data will not be acquired until there is a positive signal from Software Trigger when Send Soft Trigger is clicked.

n Click Start to run the task.

n After sending the trigger signal, the result will be like this:

Figure 13 Software trigger Acquisition


External Analog Trigger

Help > Operating PCIe/PXIe-5310 > Trigger Source > External Analog Trigger
External Analog Trigger

User can assign one of measurement channels as the analog trigger source. This module provides three kind of analog trigger: Edge comparator, hysteresis comparator and window comparator. User can select the different analog trigger comparator by setting the parameter "comparator".

Analog trigger threshold can be set arbitrarily in the effective range of the selected channel. When setting the threshold, pay attention to the physical unit currently in use.

Edge comparator

In the Edge comparator, there are two trigger conditions. One is measured value above the specified threshold which is called "Rising Slope Trigger". Another is measured value below the specified threshold which is called "Falling Slope Trigger".

"Rising Slope Trigger": The Edge comparator will output high when the signal go above the threshold. And it will change to low when the signal goes below the threshold as shown in Figure 14 .

"Falling Slope Trigger": The Edge comparator will output high when the signal go below the threshold. And it will change to low when the signal goes above the threshold as shown in Figure 15 .

Figure 14 Rising Slope Trigger

Figure 15 Falling Slope Trigger

Hysteresis comparator

The hysteresis comparator is designed for preventing spurious triggering. User can set hysteresis region by setting high threshold and low threshold. There are two trigger conditions. One is signal passing the hysteresis region from low threshold to high threshold which is called "Hysteresis with Rising Slope Trigger". Another is signal passing the hysteresis region from high threshold to low threshold which is called "Hysteresis with Falling Slope Trigger".

"Hysteresis with Rising Slope Trigger”: The Hysteresis comparator will output high when the signal must first be below the low threshold, then go above the high threshold. It will change to low when the signal goes below the low threshold as shown in Figure 16 .

"Hysteresis with Falling Slope Trigger”: The Hysteresis comparator will output high when the signal must first be above the high threshold, then go below the low threshold. It will change to low when the signal goes above the high threshold as shown in Figure 17 .

Figure 16 Hysteresis with Rising Slope Trigger

Figure 17 Hysteresis with Falling Slope Trigger

Window comparator

The window comparator is designed to acquire signal from interesting window by setting High Threshold and Low Threshold. There are two trigger conditions. One is acquired the signal inside of the window which is call ed "Entering Window Trigger". Another is acquired the signal outside of the window which is called "Leaving Window Trigger".

"Entering Window Trigger”: The window comparator will output high when the signal enters the window defined by the Low Threshold and High Threshold. And it will output low when the signal leaves the window as shown in Figure 18 .

"Leaving Window Trigger”: The window comparator will output high when the signal leaves the window defined by the Low Threshold and High Threshold. And it will output low when the signal enters the window as shown in Figure 19 .

Figure 18 Entering Window Trigger

Figure 19 Leaving Window Trigger


Learn by Example 4.4.3

Help > Operating PCIe/PXIe-5310 > Trigger Source > External Analog Trigger > Learn by Example 4.4.3
Learn by Example 4.4.3

n Connect the signal source’s positive terminal Ch1 to PCIe/PXIe-5310 AI Ch0 positive (AI0+, Pin#66), the negative terminal to AI Ch0 negative (AI0-, Pin#32) as shown in Figure 2 and Table 3 TB-68 Front Panel for 5310 Series . (AI0+, AI0-) consists of a DIFF input.

n Set the signal source Ch1’s output to sinewave signal (f=5Hz, Vpp=5v).

n Open Analog Input-->Winform AI Continuous Analog Trigger, set the following numbers as shown.

Figure 20 Analog Trigger Paraments

Ø Trigger source can be any channel of PCIe/PXIe-5310 analog input. Set it to Channel_0.

Ø Comparators of the Analog Trigger are set by Trigger Comparator. Set it to Edge.

Ø Trigger edges (rising/falling) are set by Trigger Edge. Set it to Rising.

Ø According to the rules of Edge comparator mentioned above, the Edge comparator will output high when the signal go above the threshold (2.0V).

n Click Start, a message will appear in the lower left corner:

Figure 21 Waiting For Trigger

Ø This indicates the data acquisition will start only after a triggering event. In this example a trigger signal will occur when the Edge comparator is activated.

Figure 22 Analog Trigger Acquisition

Ø The signal starts at 2.0V, which matches the RisingEdge mode set before.


External Digital Trigger

Help > Operating PCIe/PXIe-5310 > Trigger Source > External Digital Trigger
External Digital Trigger

The module supports different external digital trigger sources from PXI Trigger bus (PXI_TRIG<0..7>), PXI_STAR and connectors of front panel (PFI). The high pulse width of digital trigger signal must be longer than 20 ns for effective trigger. The module will monitor the signal on digital trigger source and wait for the rising edge or falling edge of digital signal which depending on the set trigger condition, then cause the module to acquire the data as shown in Figure 23.

Figure 23 External Digital Trigger


Learn by Example 4.4.4

Help > Operating PCIe/PXIe-5310 > Trigger Source > External Digital Trigger > Learn by Example 4.4.4
Learn by Example 4.4.4

n Connect the signal source’s two positive terminals Ch1, Ch2 to PCIe/PXIe-5310 AI Ch0 positive (AI0+, Pin#66) and digital trigger source (PFI0, Pin#1), two negative terminals to AI Ch0 negative (AI0-, Pin#32) and the ground for digital operations (DGND, Pin#5) as shown in Figure 2 and Table 3 TB-68 Front Panel for 5310 Series. (AI0+, AI0-) consists of a DIFF input. (PFI0, DGND) provides the trigger signal.

n Set the signal source Ch1’s output to sinewave signal (f=5Hz, Vpp=5v), Ch2’s output to squarewave signal (f=5Hz, VH=3.3v, VL=0v).

n Open Analog Input-->Winform AI Continuous Digital Trigger, set the following numbers as shown.

Figure 24 Digital Trigger Paraments

Ø Trigger Source must match the pin on PCIe/PXIe-5310.

Ø There are two Trigger Edge: Rising and Falling.

n Click Start and the result is shown below:

Figure 25 Digital Trigger Acquisition

Ø Since The squarewave is used for the digital trigger source, when a rising edge of the squarewave occurs, the digital trigger will be activated, and the data acquisition will start.


Trigger Mode

Help > Operating PCIe/PXIe-5310 > Trigger Mode
Trigger Mode

PCIe/PXIe-5310 supports several trigger modes: start trigger, reference trigger, and Retrigger. Please see the provided software examples for more information.


Start Trigger

Help > Operating PCIe/PXIe-5310 > Trigger Mode > Start Trigger
Start Trigger

In this mode, data acquisition begins immediately after the trigger. This trigger mode is suitable for continuous acquisition and finite acquisition. As shown in Figure 26 . Please see the provided software examples for more information.

Figure 26 Start Trigger


Reference Trigger

Help > Operating PCIe/PXIe-5310 > Trigger Mode > Reference Trigger
Reference Trigger

This trigger mode is suitable for finite acquisition. In this mode, user can set the number of pre-trigger samples. The default number of pre-trigger points is 0. First, you need to start the acquisition task and then the acquisition task will return the acquired data when the trigger condition is met. An example is shown below.

Example

l Total samples: 1000;

l Channel Count: 1

l Pre-trigger samples: 10;

l It returns total 1000 samples, 10 samples to be acquired before trigger, 990 samples after trigger.

The acquisition timing is shown in Figure 27. Please see the provided software examples for more information.

Figure 27 Reference Trigger


ReTrigger

Help > Operating PCIe/PXIe-5310 > Trigger Mode > ReTrigger
ReTrigger

PCIe/PXIe-5310 series modules support retrigger mode. In the retrigger mode, you can set the number of trigger times and the length of each acquisition. Assuming that the number of trigger times is N and the length of each trigger acquisition is M, the length of all acquisition data is N * M * channelcounts as shown in Figure 28.

When the number of trigger times is - 1, it will wait on trigger infinitely.

Figure 28 Re-Trigger


Learn by Example 4.5

Help > Operating PCIe/PXIe-5310 > Trigger Mode > Learn by Example 4.5
Learn by Example 4.5

n Connect the signal source’s positive terminal Ch1 to PCIe/PXIe-5500 AI Ch0 positive (AI0+, Pin#66), the negative terminal to AI Ch0 negative (AI0-, Pin#32) as shown in Figure 2 and Table 3. (AI0+, AI0-) consists of a DIFF input.

n Set the signal source Ch1’s output to sinewave signal (f=5Hz, Vpp=5v).

n Open Analog Input-->Winform AI Finite Analog Trigger, set the following numbers as shown.

Figure 29 Retrigger Paraments

Ø You can use three different kinds of triggers in this program as mentioned in this chapter. Start Trigger and Reference Trigger can be set by Trigger Mode. For ReTrigger it can be used by changing the numbers in Retrigger Count.

Ø pretrigger points is set by Pretrigger Sample.

n Now the Trigger Mode is “Start”. Click Start to begin the data acquisition, the result is shown below:

Figure 30 Retrigge rIn Start Trigger Mode

n Now change the Trigger Mode to Reference mode with Pretrigger Sample 1000. A different result is shown below:

Figure 31 Retrigger in Reference Trigger Mode

Ø You can see the data acquisition starts with 1000 samples earlier than before due to the change of Trigger Mode.

n Now change the mode of trigger to Retrigger through giving Retrigger Count a number “3”, then click Start. A message will appear in the lower left corner: “Complete the n trigger”.

Figure 32 Retrigger Paraments

Figure 33 Retrigger Complete State

Ø It shows the acquisition process through every trigger signal.


Digital I/O Operations

Help > Operating PCIe/PXIe-5310 > Digital I/O Operations
Digital I/O Operations

PCIe/PXIe-5310 provides powerful programmable digital I/O functions. Please see the provided software examples for more information.


Static DI/DO

Help > Operating PCIe/PXIe-5310 > Digital I/O Operations > Static DI/DO
Static DI/DO

Programmable I/O supports static TTL, 8 ports<0..7> with 2 lines which is total 16 channels digital I/O. User can read these I/O information through software polling.


Learn by Example 4.6.1

Help > Operating PCIe/PXIe-5310 > Digital I/O Operations > Static DI/DO > Learn by Example 4.6.1
Learn by Example 4.6.1

n In this example PCIe/PXIe-5310 outputs a digital signal by its DO function and reads it back by its DI function.

n Connect PCIe/PXIe-5310 Port 0~2’s Line 0~1 to Port 3~5’s Line 0~1. Connections represented in Pins: (Pin1àPin4) (Pin2àPin6) (Pin3àPin7) (Pin35àPin38) (Pin36àPin40) (Pin37àPin41). PCIe/PXIe-5310 sends digital signals through Port 3~5 and reads them back from Port 0~2.

n Open the first program Digital Output-->Winform DO SinglePoint.

n Select all ports for digital output, Set Line 7,9,11 in High-Level positions, make sure all other lines are in Low-Level positions. Click Start to generate the High-Levels as shown.

Figure 34 Single Digital Output

n Open the second program Digital Input-->Winform DI SinglePoint.

n Select all ports for digital input as shown, and click Start. The result is shown below.

Figure 35 Single Digital Input

Ø The result shows that the digital signals are successfully transferred between Port3~5 and Port 0~2.


Multi-Devices Synchronization

Help > Operating PCIe/PXIe-5310 > Multi-Devices Synchronization
Multi-Devices Synchronization

PCIe/PXIe-5310 Series modules multi-devices synchronization support two methods : ReferenceClockSynchronization and SampelClockSynchronization

ReferenceClockSynchronization

This method will use 3 signals, Reference clock, Sync Pulse and Triger to achieve data acqusistion simultaneously with multiple modules. First, the master module will notice all of slave modules by routing the trigger signal through PXI trigger bus, PXI_TRIG<0..7> when master module receives trigger. Second, we also need to make sure every module to start the acquisition task in the same time, therefore we could take advange of PXI system which can provide a synchronization pulse, PXIe_SYNC100 to coordinate with the acquisition task of multiple modules.

Third, every module must use the same reference clock to keep pace with each others and user can use PXIe_CLK100 which provides by PXI system as reference clock.

The timing diagram is shown as Figure 36 .

Figure 36 Timing diagram

To enable the multi-card synchronization, configure the board as follows:

1. Set each task on different card as Master or Slave. Only one master is allowed.

2. Set the reference clock source of master card and slave card to PXIe_CLK100.

3. Route trigger signals of all tasks to the same signal terminal, trigger signal will be sent from the master card to all slave cards through this terminal.

4. Route Sync Pulse signals of all tasks to the same signal terminal, Sync Pulse signals will be sent from the master card to all slave cards through this terminal.

5. Start all slave tasks.

6. Start the master task (if digital trigger or software trigger is enabled, you need to wait for the trigger signal to arrive), all the tasks will start to work synchronously on a rising edge of the PXIe_SYNC100 signal.

Note: The method is only valid for PXIe device.

SampelClockSynchronization

This method will use 2 signals, Sample clock and Triger to achieve data acqusistion simultaneously with multiple modules. First, the master module will routing the Sample clock signal to PXI trigger bus, PXI_TRIG<0..7> , then the slave module must selsect the same PXI trigger bus as the Sample Clock source . Second the master module will notice all of slave modules by routing the trigger signal through PXI trigger bus, PXI_TRIG<0..7> when master module receives trigger.

To enable the multi-card synchronization, configure the board as follows:

1. Set each task on different card as Master or Slave. Only one master is allowed.

2. Export the SampleClock of master card to PXI trigger bus(PXI_TrigN), then the slave cards select the same PXI trigger bus(PXI_TrigN) as external sample clock.

3. Export the trigger signal of master card to PXI trigger bus(PXI_TrigN), then the slave cards select the same PXI trigger bus(PXI_TrigN) as digital trigger source.

4. Start all slave tasks.

5. Start the master task (if digital trigger or software trigger is enabled, you need to wait for the trigger signal to arrive), all the tasks will start to work synchronously.


System Synchronization Interface（SSI）for PCIe Modules

Help > Operating PCIe/PXIe-5310 > System Synchronization Interface（SSI）for PCIe Modules
System Synchronization Interface（SSI）for PCIe Modules

The synchronization between PCIe modules are handled differently from the PXIe synchronization, it is implemented by the system synchronization interface (SSI). SSI is designed as a bidirectional bus and it can synchronize up to four PCIe modules. One PCIe module is designated as the master module and the other PCIe modules are designated as the slave modules.

Figure 37 SSI Connector in PCIe-5310

Table 17 SSI Connector Pin Assignment for PCIe-5310


DIP Switch in PCIe-5310

Help > Operating PCIe/PXIe-5310 > DIP Switch in PCIe-5310
DIP Switch in PCIe-5310

PCIe-5310 series board has a DIP switch. The card number can be adjusted manually by changing the DIP switch setting, which is used to identify the boards with different slot positions.

For example, if you want to set the card number to 3, you could turn the position 2 and 1 of the DIP switch to the ON position and the orthers to OFF. See below for details.

Figure 38 DIP Switch in PCIe-5310

Table 18 Relationship between switch position and slot number


Calibration

Help > Calibration
Calibration

JY-5310 board is precalibrated before the shipment. We recommend you recalibrate your JY-5310 board periodically to ensure the measurement accuracy. A commonly accepted practice is one year. If you need to recalibrate your board, please contact JYTEK.


JYTEK China

Help > About JYTEK > JYTEK China
JYTEK China

Founded in June, 2016, JYTEK China is a leading Chinese test & measurement company, providing complete software and hardware products for the test and measurement industry. The company is a joint venture between Adlink Technologies and a group of experienced professionals form the industry. JYTEK independently develop the software and hardware products and is entirely focused on the Chinese market. Our Shanghai headquarters and production service center have regular stocks to ensure timely supply; we have R&D centers in Xi'an and Chongqing to develop new products; we also have highly trained direct technical sales representatives in Shanghai, Beijing, Tianjin, Xi'an, Chengdu, Nanjing, Wuhan, Haerbin, and Changchun. We also have many partners who provide system level support in various cities.


JYTEK Korea and JYTEK In Other Countries

Help > About JYTEK > JYTEK Korea and JYTEK In Other Countries
JYTEK Korea and JYTEK In Other Countries

JYTEK Korea was the first JYTEK enterprise outside China to promote JYTEK products. Together with Adlink Technologies and JYTEK China, JYTEK is expanding to more countries. Each JYTEK location is an independently owned and operated franchise. It shares JYTEK’s philosophy and business approach. Together JYTEK entities promote the JYTEK brand, technology, and products.


JYTEK Hardware Products

Help > About JYTEK > JYTEK Hardware Products
JYTEK Hardware Products

According to JYTEK’s agreement with our equity partner Adlink Technologies, JYTEK’s hardware is manufactured by the state-of-art manufacturing facility located in Shanghai Zhangjiang Hi-Tech Park. Adlink has over 20 years of the world-class low-volume and high-mix manufacturing expertise with ISO9001-2008, China 3C, UL, ROHS, TL9000, ISO-14001, ISO-13485 certifications. Its 30,000 square meters facilities and three high-speed Panasonic SMT production lines can produce 60,000 pieces boards/month; it also has full supply chain management - planning, sweeping, purchasing, warehousing and distribution. Adlink’s manufacturing excellence ensures JYTEK’s hardware has word-class manufacturing quality.

One core technical advantage is JYTEK’s pursue for the basic and fundamental technology excellence. JYTEK China has developed a unique PCIe, PXIe, USB hardware driver architecture, FirmDrive, upon which many our future hardware will be based.

In addition to our own developed hardware, JYTEK also rebrands Adlink’s PXI product lines. In addition, JYTEK has other rebranding agreements to increase our hardware coverage. It is our goal to provide the complete product coverage in PXI and PCI modular instrumentation and data acquisition.


JYTEK Software Platform

Help > About JYTEK > JYTEK Software Platform
JYTEK Software Platform

JYTEK has developed a complete software platform, SeeSharp Platform, for the test and measurement applications. We leverage the open sources communities to provide the software tools. Our platform software is also open sourced and is free, thus lowering the cost of tests for our customers. We are the only domestic vendor to offer complete commercial software and hardware tools.


JYTEK Warranty and Support Services

Help > About JYTEK > JYTEK Warranty and Support Services
JYTEK Warranty and Support Services

With our complete software and hardware products, JYTEK is able to provide technical and sales services to wide range of applications and customers. In most cases, our products are backed by a 1-year warranty. For technical consultation, pre-sale and after-sales support, please contact JYTEK of your country.


Typical Measurement Error

Help > Appendix > Typical Measurement Error
Typical Measurement Error

图表, 折线图 描述已自动生成

Figure 39 Measurement Error


System Noise

Help > Appendix > System Noise
System Noise

Table 19 Random Noise

图表, 条形图, 直方图 描述已自动生成

Figure 40 Random Noise

When measuring system noise, the board input bias current must have a return path to its local analog ground. In order to eliminate the bias, it is necessary to connect a ground resistance to the channel, and the resistance should be more than 1MΩ.

Figure 41 Creating an [image] Return Path


Temperature Drift

Help > Appendix > Temperature Drift
Temperature Drift

图表, 折线图 描述已自动生成

Figure 42 Gain Error due to Temperature Change

图表, 折线图 描述已自动生成

Figure 43 Offset Error due to Temperature Change


Statement

Help > Statement
Statement

The hardware and software products described in this manual are provided by JYTEK China, or JYTEK in short.

This manual provides the product review, quick start, some driver interface explanation for JYTEK PCIe/PXIe-5500 Series family of multi-function data acquisition boards. The manual is copyrighted by JYTEK.

No warranty is given as to any implied warranties, express or implied, including any purpose or non-infringement of intellectual property rights, unless such disclaimer is legally invalid. JYTEK is not responsible for any incidental or consequential damages related to performance or use of this manual. The information contained in this manual is subject to change without notice.

While we try to keep this manual up to date, there are factors beyond our control that may affect the accuracy of the manual. Please check the latest manual and product information from our website.

Shanghai Jianyi Technology Co., Ltd.

Address: Room 201, Building 3, NO.300 Fangchun Road, Shanghai.

Post Code: 201203

Tel: 021-5047 5899

Website: www.jytek.com